summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ffa2eca..725aba8 100644
--- a/meson.build
+++ b/meson.build
@@ -6,6 +6,7 @@ project('minecproxy',
default_options : [
'c_std=gnu18',
'sysconfdir=/etc',
+ 'sharedstatedir=/var/lib',
'warning_level=2',
'b_lto=true',
]
@@ -38,8 +39,8 @@ ld_extra_flags = [
ld_flags += cc.get_supported_link_arguments(ld_extra_flags)
add_project_link_arguments(ld_flags, language: 'c')
-sysconfdir = join_paths(get_option('prefix'), get_option('sysconfdir'), meson.project_name())
-localstatedir = join_paths(get_option('prefix'), get_option('localstatedir'), meson.project_name())
+sysconfdir = join_paths(get_option('sysconfdir'), meson.project_name())
+localstatedir = join_paths(get_option('prefix'), get_option('sharedstatedir'), meson.project_name())
mainconfname = meson.project_name() + '.conf'
conf = configuration_data()