summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Härdeman <david@hardeman.nu>2020-07-06 20:57:33 +0200
committerDavid Härdeman <david@hardeman.nu>2020-07-06 20:57:33 +0200
commit76ee64b5b3e30706181becbf33cc45d67f39f364 (patch)
tree27ef23d5026469258d7fad09c74c4dd9d0ffbed5 /debian/rules
parentc9c5028018a588baad2c1af6dcfa3325bc18d02c (diff)
Add some license information and the beginning of Debian packages
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..74af31b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+
+%:
+ dh $@
+
+
+# dh_make generated override targets
+# This is example for Cmake (See https://bugs.debian.org/641051 )
+#override_dh_auto_configure:
+# dh_auto_configure -- # -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
+