summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Härdeman <david@hardeman.nu>2020-07-12 00:00:26 +0200
committerDavid Härdeman <david@hardeman.nu>2020-07-12 00:00:26 +0200
commitb56b003fc13a4e12f97c6cfd5dd650e928d6e016 (patch)
treea68b48604bccd9a96225bf1c3be21fc05a022b6b /meson.build
parente6fdfd4c4c753fe3a06edc4ae3b767c57c10d3f7 (diff)
Teach minecctl to split things into data and cfg dir, also read config variables from the server.properties file
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a88b523..ffa2eca 100644
--- a/meson.build
+++ b/meson.build
@@ -39,11 +39,13 @@ ld_flags += cc.get_supported_link_arguments(ld_extra_flags)
add_project_link_arguments(ld_flags, language: 'c')
sysconfdir = join_paths(get_option('prefix'), get_option('sysconfdir'), meson.project_name())
+localstatedir = join_paths(get_option('prefix'), get_option('localstatedir'), meson.project_name())
mainconfname = meson.project_name() + '.conf'
conf = configuration_data()
conf.set_quoted('VERSION', '@0@-@VCS_TAG@'.format(meson.project_version()))
conf.set_quoted('DEFAULT_CFG_DIR', sysconfdir)
+conf.set_quoted('DEFAULT_DATA_DIR', localstatedir)
conf.set_quoted('DEFAULT_MAIN_CFG_FILE', mainconfname)
inc_config_h = include_directories('.')