summaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
new file mode 100644
index 0000000..e50f459
--- /dev/null
+++ b/examples/meson.build
@@ -0,0 +1,29 @@
+# SPDX-License-Identifier: GPL-2
+
+example_files = [
+ 'eula.txt',
+ 'example.mcserver',
+ 'minecproxy.conf',
+ 'minecproxy.service',
+ 'minecserver@.service',
+ 'README.TXT',
+ 'server.properties',
+]
+
+xxd = find_program('xxd')
+
+xxd_cmd = [xxd, '-i', '@INPUT@', '@OUTPUT@']
+
+foreach example_file: example_files
+ example_output = example_file + '.h'
+
+ file = custom_target(
+ example_output,
+ input: example_file,
+ output: example_output,
+ command: xxd_cmd,
+ build_by_default: true,
+ )
+endforeach
+
+