summaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build21
1 files changed, 14 insertions, 7 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 5d3564b..7b525f6 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,8 +1,7 @@
# SPDX-License-Identifier: GPL-2
-example_files = [
+xxd_files = [
'eula.txt',
- 'example.mcserver',
'minecctl.conf',
'minecproxy.conf',
'minecproxy.service',
@@ -14,16 +13,24 @@ xxd = find_program('xxd')
xxd_cmd = [xxd, '-i', '@INPUT@', '@OUTPUT@']
-foreach example_file: example_files
- example_output = example_file + '.h'
+foreach xxd_file: xxd_files
+ xxd_output = xxd_file + '.h'
file = custom_target(
- example_output,
- input: example_file,
- output: example_output,
+ xxd_output,
+ input: xxd_file,
+ output: xxd_output,
command: xxd_cmd,
build_by_default: true,
)
endforeach
+install_files = [
+ 'example.mcserver',
+ 'minecctl.conf',
+ 'minecproxy.conf',
+ 'minecproxy.service',
+ 'minecserver@.service',
+]
+